Discussion:
"Failed to create OpenGL context..."
Add Reply
d***@gmail.com
2018-07-12 15:45:35 UTC
Reply
Permalink
Raw Message
Hello, I've just installed version 2.6 and am getting the following error when I try to open:

Failed to create OpenGL cotext for format QSurfaceFormat...

Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries are available in the application executable's directory or in a location listed in PATH.

I have already downloaded the drivers suggested by mnemosyne. Any help is appreciated. Thanks.
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/97b72936-9971-4082-9556-7ec1dc830d8e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Peter Bienstman
2018-07-13 03:38:59 UTC
Reply
Permalink
Raw Message
Hi,

Please try the tips mentioned here:

https://mnemosyne-proj.org/download-mnemosyne.php

Cheers,

Peter
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/f89d2c2a-ee83-41ba-abea-ecbefd2704b8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
w***@gmail.com
2018-08-15 21:20:09 UTC
Reply
Permalink
Raw Message
My father in law has been using Mnemosyne for the few years on old Windows 10 laptop.

After installation of 2.6.1 version (with prior manual uninstall of 2.6) it started to display the same message.

I have unsuccesfully tried different solutions suggested in Internet: install graphics drivers (difficult, because last supported by Intel driver was developed for Windows7), install unsinged drivers, install DirectX 9,10, install Angle OpenGL libraries etc.

After the few days I have found temporary workaround:
1. I uninstalled M 2.6.1.
2. I installed M 2.5 - this version worked without any problems.
3. I installed M 2.6.1 WITHOUT UNINSTALLATION of 2.5.

I surmise that problem is the result of e.g. misconfiguration of Qt5, and not old or missing drivers.
Now M 2.6.1 works without problems, besides startup time - it lasts about 1 minute - quite long.

Regards,
Wojtek
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/6cfe8e52-d1ca-405d-a444-52c1deadb7de%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Peter Bienstman
2018-08-16 07:37:21 UTC
Reply
Permalink
Raw Message
Thanks for posting this workaround!

2.5 is bundled with an older version of Qt. I'll try to look if there are files left over from 2.5 if you install 2.6.1 on top of it. The long startup time might be related to this issue as well...

Cheers,

Peter

-----Original Message-----
From: mnemosyne-proj-***@googlegroups.com <mnemosyne-proj-***@googlegroups.com> On Behalf Of ***@gmail.com
Sent: 15 August 2018 23:20
To: mnemosyne-proj-users <mnemosyne-proj-***@googlegroups.com>
Subject: [mnemosyne-proj-users] Re: "Failed to create OpenGL context..."

My father in law has been using Mnemosyne for the few years on old Windows 10 laptop.

After installation of 2.6.1 version (with prior manual uninstall of 2.6) it started to display the same message.

I have unsuccesfully tried different solutions suggested in Internet: install graphics drivers (difficult, because last supported by Intel driver was developed for Windows7), install unsinged drivers, install DirectX 9,10, install Angle OpenGL libraries etc.

After the few days I have found temporary workaround:
1. I uninstalled M 2.6.1.
2. I installed M 2.5 - this version worked without any problems.
3. I installed M 2.6.1 WITHOUT UNINSTALLATION of 2.5.

I surmise that problem is the result of e.g. misconfiguration of Qt5, and not old or missing drivers.
Now M 2.6.1 works without problems, besides startup time - it lasts about 1 minute - quite long.

Regards,
Wojtek
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/6cfe8e52-d1ca-405d-a444-52c1deadb7de%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/3f6fdf21da0a40ffbbda1673ec7e4ba6%40xmail101.UGent.be.
For more options, visit https://groups.google.com/d/optout.
Peter Bienstman
2018-08-22 18:53:27 UTC
Reply
Permalink
Raw Message
Hi,

This version should come with some missing libraries:

https://www.dropbox.com/s/dv2aq2jzctwkfef/mnemosyne-2.6.1-setup.exe?dl=0

Feedback would be appreciated!

Cheers,

Peter
Post by Peter Bienstman
Thanks for posting this workaround!
2.5 is bundled with an older version of Qt. I'll try to look if there are
files left over from 2.5 if you install 2.6.1 on top of it. The long
startup time might be related to this issue as well...
Cheers,
Peter
-----Original Message-----
Sent: 15 August 2018 23:20
Subject: [mnemosyne-proj-users] Re: "Failed to create OpenGL context..."
My father in law has been using Mnemosyne for the few years on old Windows 10 laptop.
After installation of 2.6.1 version (with prior manual uninstall of 2.6)
it started to display the same message.
install graphics drivers (difficult, because last supported by Intel driver
was developed for Windows7), install unsinged drivers, install DirectX
9,10, install Angle OpenGL libraries etc.
1. I uninstalled M 2.6.1.
2. I installed M 2.5 - this version worked without any problems.
3. I installed M 2.6.1 WITHOUT UNINSTALLATION of 2.5.
I surmise that problem is the result of e.g. misconfiguration of Qt5, and
not old or missing drivers.
Now M 2.6.1 works without problems, besides startup time - it lasts about
1 minute - quite long.
Regards,
Wojtek
--
You received this message because you are subscribed to the Google Groups
"mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
To view this discussion on the web visit
https://groups.google.com/d/msgid/mnemosyne-proj-users/6cfe8e52-d1ca-405d-a444-52c1deadb7de%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/1a5ee90e-1fd7-4208-bcc9-c2d7c7068acd%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Wojtek
2018-08-22 19:38:22 UTC
Reply
Permalink
Raw Message
Thank you. I will try this next weekend as now I went away.

Regards,
Wojtek
Post by Peter Bienstman
Hi,
https://www.dropbox.com/s/dv2aq2jzctwkfef/mnemosyne-2.6.1-setup.exe?dl=0
Feedback would be appreciated!
Cheers,
Peter
Post by Peter Bienstman
Thanks for posting this workaround!
2.5 is bundled with an older version of Qt. I'll try to look if there are
files left over from 2.5 if you install 2.6.1 on top of it. The long
startup time might be related to this issue as well...
Cheers,
Peter
-----Original Message-----
Sent: 15 August 2018 23:20
Subject: [mnemosyne-proj-users] Re: "Failed to create OpenGL context..."
My father in law has been using Mnemosyne for the few years on old Windows 10 laptop.
After installation of 2.6.1 version (with prior manual uninstall of 2.6)
it started to display the same message.
install graphics drivers (difficult, because last supported by Intel driver
was developed for Windows7), install unsinged drivers, install DirectX
9,10, install Angle OpenGL libraries etc.
1. I uninstalled M 2.6.1.
2. I installed M 2.5 - this version worked without any problems.
3. I installed M 2.6.1 WITHOUT UNINSTALLATION of 2.5.
I surmise that problem is the result of e.g. misconfiguration of Qt5, and
not old or missing drivers.
Now M 2.6.1 works without problems, besides startup time - it lasts about
1 minute - quite long.
Regards,
Wojtek
--
You received this message because you are subscribed to the Google Groups
"mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an
To post to this group, send email to
To view this discussion on the web visit
https://groups.google.com/d/msgid/mnemosyne-proj-users/6cfe8e52-d1ca-405d-a444-52c1deadb7de%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to a topic in the
Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/mnemosyne-proj-users/5VlbndHwIPk/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
.
To view this discussion on the web visit
https://groups.google.com/d/msgid/mnemosyne-proj-users/1a5ee90e-1fd7-4208-bcc9-c2d7c7068acd%40googlegroups.com
<https://groups.google.com/d/msgid/mnemosyne-proj-users/1a5ee90e-1fd7-4208-bcc9-c2d7c7068acd%40googlegroups.com?utm_medium=email&utm_source=footer>
.
For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "mnemosyne-proj-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to mnemosyne-proj-users+***@googlegroups.com.
To post to this group, send email to mnemosyne-proj-***@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/mnemosyne-proj-users/CABsr%2Bi4ANsjE9exujiLYLPunXwNVk5g9EU_%2BQJXuDJ%2BgSwuwVg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Loading...